PDA

View Full Version : Question



85svoguy
12-18-2009, 10:18 AM
Alright guys, I have an 84 SVO. Recently had a bad fuel leak from the lines coming off the fuel rail so the injectors burnt themselves out. Replaced the injectors, and tps because one of the tabs broke. The car starts, but idles like crap, running rich, drives normal but as soon as it sees any kind of boost it bogs like crazy and won't go anywhere. Backfiring a little bit too. The car is completely stock except for a manual boost controller. What are some possible solutions? Wires and plugs havent been changed in a while. Fuel filter changed last year.

TheSVOTrust-MarkHaas
12-18-2009, 02:25 PM
Guess I would ask "if all you changed" was the injectors.........can you confirm what you put in?

Need to know where you got them (store what brand number)
OR if you had "other" injectors (used) etc etc.

From there we can test fuel system if needed. BEFORE you get into the spark. (way too easy to confuse fuel problem with spark problems)

Mark
P.S. Yes wires are important - but that could also put you in a "chasing a problem" mode IF you mess that up with wrong plug gaps, or wires !

85svoguy
12-18-2009, 02:41 PM
Guess I would ask "if all you changed" was the injectors.........can you confirm what you put in?

Need to know where you got them (store what brand number)
OR if you had "other" injectors (used) etc etc.

From there we can test fuel system if needed. BEFORE you get into the spark. (way too easy to confuse fuel problem with spark problems)

Mark
P.S. Yes wires are important - but that could also put you in a "chasing a problem" mode IF you mess that up with wrong plug gaps, or wires !

Yes I used some 450cc (42lbers) bosch style injectors. I think they were out of a DSM and they are low impedance. I also replaced the plastic clips that go on the fuel lines with ones that weren't broken. That was all i changed out. Wires, and Plugs haven't been changed out, for I would say 30,000 miles.

wicked93gs
12-20-2009, 03:50 PM
hmm, replacing 36lbers with 42lbers and you wonder why its running rich? get the right injectors or an adjustable FPR and lower the pressure...though too low and the injectors dont spray so much as drip...to me it seems like you need to get fuel flow under control first