PDA

View Full Version : Not Getting spark!



M Pizle
07-12-2013, 12:29 PM
Hey guys, Im new to the forum so ill just get right into it, I recently got an 84' SVO and I love it but the guy before me put in an MSD ignition and while I was driving home from work the engine died... Its like its not getting any gas but I checked all the lines and pump and they all work, I changed the plugs and wires and it still wont fire up. I thought maybe the ignition coil so I swapped that out and still nothing. Next I had a local shop check the ignition module and it came back as working... Im losing my mind on it because the previous owner hacked some wires and now im lost... can someone give me some ideas on things to try or correct me on things, this is my first SVO, I was big into the rotaries and those are a whole different monster haha. I should add that I drove it close to 100 miles before this happened

NotBud
07-13-2013, 07:39 AM
A few questions back at 'cha to start:

- Does the tach needle bounce when cranking?
- Is the distributor rotor turning (rotating) when cranking?
- Does the engine, when cranking, make a normal suck-compress-expell sound or does it sound like it's free-spinning?

M Pizle
07-13-2013, 09:19 AM
Tach bounces once when you turn the key "on" but when cranking it goes dead, engine sounds good, and the distributor is good as far as I can tell... I think that's the next thing to check... im getting frustrated

TheSVOTrust-MarkHaas
07-13-2013, 11:10 AM
Have someone crank the car -while you look behind the cam cover.

Not spinning - change the belt
Spinning - fix the aux gear

Mark

M Pizle
07-13-2013, 02:48 PM
well Ive been kinda busy so I havnt had time to do anything but I checked the ignition coil and right when you first crank on it it gets one spark and thats it... any help with that?

NotBud
07-14-2013, 09:52 AM
Dizzy is not turning. Could be dizzy gear / auxiliary shaft gear / cam belt. If the dizzy gear is gone, replace the dizzy gear, auxiliary shaft and the oil pump.

Check / repair them in that order.

And STOP cranking it until this is fixed - there is no oil pressure.

( Samekles Plug: I have NOS auxiliary shafts available. )

M Pizle
07-14-2013, 12:06 PM
Thank you for the help, Ill look into it and let you know what's happening,